ZX Forums - Reply to Topic
Thread: Defective Speedo Cable Clamp Reply to Thread
Title:
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the ZX Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
04-08-2019 07:44 PM
buckshot
Defective Speedo Cable Clamp

For several years now, I have been unable to permanently attach the plastic speedo cable clamp back into the hole in the left side of the front fender. It is apparent that the plastic split dome that pushes through the hole has simply worn out. I have tried using silicone a few times but it is just not compatible with the plastic clip or the fender.

I checked with my local Kawasaki dealer to try and order a new one however they tell me that p/n 92170-1186 is no longer available which doesn't surprise me on a 20 year old bike. I could try a local cycle salvage graveyard near Peterborough but that would be like finding a needle in a haystack! I'd prefer to still have something there to stop the cable from flapping around and could likely jerry-rig something else such as using a large plastic zip tie. Perhaps a newer model bike has a part that would work.

Thought I'd just throw it out to see what others have done to either get it to stay attached or have done something else.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome