ZX Forums - Reply to Topic
Thread: 07 Zx6r won’t crank Reply to Thread
Title:
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the ZX Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
08-26-2019 08:01 PM
Joshuaorr3
07 Zx6r won’t crank

I’m starting to think it could be the starter relay in the junction box any other thoughts out there
08-25-2019 10:48 AM
Luis Octavio Carneiro Hi. My name is Luis and I have recently bought my zx9r 1998. I bought it last week and I still have not read the service manual completely but I was wondering:Have you checked all the fuses? I hope you solve your problem soon.
08-24-2019 08:30 PM
Joshuaorr3
07 Zx6r won’t crank

Hello I’m having trouble trouble shooting this problem I got an 07 Zx6r with 17k miles on it the bike ran fine till one day I was riding and the bike seem to die out while I was riding figure it was the stator and rectifier changed that out and still had the problem of a really slow start so I changed the starter and when I did that I got to start the bike and nothing all I get is a pop from the start selonoid I’ve even changed that and still the same noice all my fuses are fine replaced the battery and still can’t get the engine to turn please help

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome