98 zx7r weak spark - ZX Forums
 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 05-24-2019, 09:05 AM Thread Starter
Newbie
 
ricardokg15's Avatar
 
Joined: May 2019

Posts: 2
98 zx7r weak spark

Could anyone help me with a problem. That I have already done alot to try and resolve my issue. I started wit repairing the dreaded grey wire which I re-soldered it on the ignition switch. I have put a new fuel pump, spark plugs have been cleaned and regap to proper specs.which the bike will crank but will not start and run. Also have changed the coils. I need help to figure out this problem. And also how can I check the cdi box to see if it's good or needs to be replaced
ricardokg15 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 05-24-2019, 04:15 PM
Senior Member
 
ninjanut's Avatar
 
Joined: Dec 2011
From: hamilton,ON,Canada
I Ride: 1996 ZX7R, 1996 ZX7RR (track)

Posts: 1,940
Why did you resolder the grey wire to the ignition? If it send more or less than 6v to the CDI, it will turn over all day but never spark. I would bet your issue is still grey wire related.
ninjanut is online now  
post #3 of 4 (permalink) Old 05-24-2019, 04:55 PM Thread Starter
Newbie
 
ricardokg15's Avatar
 
Joined: May 2019

Posts: 2
No I now have spark but it's weak
ricardokg15 is offline  
post #4 of 4 (permalink) Old 05-24-2019, 07:07 PM
Senior Member
 
ninjanut's Avatar
 
Joined: Dec 2011
From: hamilton,ON,Canada
I Ride: 1996 ZX7R, 1996 ZX7RR (track)

Posts: 1,940
Did this issue just start out of the blue or was something done to the bike and now the issues? Need a little back history. For the sake of your wallet don’t just start replacing parts, it usually doesn’t end well.
Also, I would doubt it is the CDI. They can be checked against values in the service manual.
Simple things like bad wiring/connections and loose/bad grounds are very common on these bikes. Likely something simple.
ninjanut is online now  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the ZX Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Weak spark.. any ideas? alphabravo ZX-7R Forum 15 01-08-2013 12:30 PM
Weak spark Hanceformer Mechanical & Technical 3 04-08-2012 07:28 PM
weak spark zx11_dragon ZX-11 Forum 10 01-04-2010 09:14 AM
Weak Spark skyjack Mechanical & Technical 0 08-02-2009 05:12 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome