1998 zx9 wire help needed - ZX Forums
 
LinkBack Thread Tools
post #1 of 10 (permalink) Old 06-18-2009, 03:23 AM Thread Starter
Newbie
 
Joined: Jun 2009
From: Tennessee
I Ride: 1998 zx9r

Posts: 11
1998 zx9 wiring harness help needed urgently

i got my bike with no turning signals and when i was putting on the back ones i noticed while looking for which wires to connect, there are two red wires and two blue wire coming out of the biggest connector for the taillight (where the red, blue, and black wires come from the harness) that are cut along with many others that are single wire going into smaller red connectors that look like splitters but the second wire is cut off on some of them too. can anyone tell me what each color wire is for. the only thing i am sure of is the turn signals and i think i know the taillights' wires also but there are so many extras i just have no clue. also what is the black "rubber-like" box with all the wires in one side of it i will appreciate any help!

Last edited by chrissparks51998zx9r; 06-18-2009 at 05:02 AM. Reason: i left some stuff out
chrissparks51998zx9r is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 06-18-2009, 07:56 AM
Senior Member
 
dirty13south's Avatar
 
Joined: Jun 2008
From: Dallas, TX.
I Ride: 2005 ZX10R

Posts: 411
the box is the ECU (computer)! as for the wires the BK/Y & Gray are right rear turn sig. and the BK/Y & Green are left rear turn. Blue/R, Red, Bk/Y are tail/ brake light.
dirty13south is offline  
post #3 of 10 (permalink) Old 06-21-2009, 03:17 AM
Newbie
 
Joined: Jun 2009
From: LA

Posts: 3
Quote:
Originally Posted by chrissparks51998zx9r View Post
i got my bike with no turning signals and when i was putting on the back ones i noticed while looking for which wires to connect, there are two red wires and two blue wire coming out of the biggest connector for the taillight (where the red, blue, and black wires come from the harness) that are cut along with many others that are single wire going into smaller red connectors that look like splitters but the second wire is cut off on some of them too. can anyone tell me what each color wire is for. the only thing i am sure of is the turn signals and i think i know the taillights' wires also but there are so many extras i just have no clue. also what is the black "rubber-like" box with all the wires in one side of it i will appreciate any help!
I have also same problem with me. I don't know anything about automobile wirings.

Kawasaki Ninja 2007 Kawasaki Headlights
samabhi126 is offline  
post #4 of 10 (permalink) Old 06-21-2009, 08:48 PM
Newbie
 
Joined: Jun 2009
From: Chicago
I Ride: 99 ZX9r

Posts: 8
The small black rubber like box in the back by the tail light with red connector and 4 wires is the fuel pump relay. Turn signal wires would have two wires on eacj side of subframe, with bullet terminal style connectors on them
Muzzy9 is offline  
post #5 of 10 (permalink) Old 06-21-2009, 08:49 PM
Newbie
 
Joined: Jun 2009
From: Chicago
I Ride: 99 ZX9r

Posts: 8
Quote:
Originally Posted by dirty13south View Post
the box is the ECU (computer)! as for the wires the BK/Y & Gray are right rear turn sig. and the BK/Y & Green are left rear turn. Blue/R, Red, Bk/Y are tail/ brake light.
Zx9s never had an ecu.
Muzzy9 is offline  
post #6 of 10 (permalink) Old 06-22-2009, 06:29 AM
Senior Member
 
dirty13south's Avatar
 
Joined: Jun 2008
From: Dallas, TX.
I Ride: 2005 ZX10R

Posts: 411
ECU/ CDI samething...
dirty13south is offline  
post #7 of 10 (permalink) Old 06-22-2009, 01:03 PM
Newbie
 
Joined: Jun 2009
From: Chicago
I Ride: 99 ZX9r

Posts: 8
IC ignitor
Muzzy9 is offline  
post #8 of 10 (permalink) Old 06-26-2009, 11:18 PM Thread Starter
Newbie
 
Joined: Jun 2009
From: Tennessee
I Ride: 1998 zx9r

Posts: 11
well thanks for the help but i figured out it was just an aftermarket taillight with the turn signals you know, "built in". i guess that's an "integrated taillight", no?
chrissparks51998zx9r is offline  
post #9 of 10 (permalink) Old 09-29-2014, 07:00 PM
Newbie
 
Joined: Sep 2014
From: california

Posts: 6
[QUOTE=chrissparks51998zx9r;166753]well thanks for the help but i figured out it was just an aftermarket taillight with the turn signals you know, "built in". i guess that's an "integrated taillight", no?[hey chris i know this is like way old but im having the same problem years later. i cant get my blinkers to work at all. i bought the integrated taillight like you did. but how do you get it to work?]
reidbeckwith is offline  
post #10 of 10 (permalink) Old 09-30-2014, 03:09 AM
Newbie
 
Joined: Sep 2014
From: california

Posts: 6
did anyone real my post and can give me a little help? i'm having the same problems as chris. i also decided to take off all my plastics and im going to paint them all white and keep my rims the lime green
reidbeckwith is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the ZX Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome