2005 ZX6R FI Light!!! - ZX Forums
LinkBack Thread Tools
post #1 of 5 (permalink) Old 02-08-2011, 02:17 PM Thread Starter
Joined: Oct 2010
From: San Diego

Posts: 1
2005 ZX6R FI Light!!!

Hello guys,

I'm new to the forum. I have a quick question about the FI light. So when I got my 636 in september, it was fine. In november, the FI light came on at night when I was riding, I didn't think much of it since it was riding fine, nothing felt weird, and the FI light went away the next day ! Since then, it hasn't gone on ever since until a few days ago. I thought it would go away like the first time, but I was on everyday for the last couple of days. What problems could cause this, could it be because I didnt change the oil yet? And is it necessary to bring it to a dealer tech?

P.s. the bike rides perfectly, nothing seems to be weird or out of the ordinary.

fellow 636 rider
watertro88 is offline  
Sponsored Links
post #2 of 5 (permalink) Old 02-08-2011, 06:51 PM
Senior Member
Shifty1's Avatar
Joined: Jun 2008
From: Cincy, Ohio
I Ride: 2005 ZX6R

Posts: 11,783
The only way to know for sure is to pull the codes.

-Poetry written in gasoline.
Shifty1 is offline  
post #3 of 5 (permalink) Old 02-09-2011, 10:15 AM
Miyagi Yamasaki's Avatar
Joined: Sep 2010
From: Dublin, Ohio
I Ride: matte blue 2006 zx6r 636

Posts: 91
here's a link on how to pull the codes, its so easy even I can do it!

"Stock really does keep me up at night, really." - Miyagi Yamasaki

06 636 matte blue
ebay front and rear axle sliders
ebay no-cut frame sliders
Kleen block off
taped ram-air-frame-holes
Pinebox Screamer exhaust
44t superlite rear sprocket

Soon to come: Powercommander with custom dynotune!
Miyagi Yamasaki is offline  
post #4 of 5 (permalink) Old 07-31-2011, 08:24 PM
whiterabbit's Avatar
Joined: Jul 2011
From: North Lauderdale

Posts: 38
Originally Posted by Miyagi Yamasaki View Post
here's a link on how to pull the codes, its so easy even I can do it!
thanks man, I need it. my FI is driving me nuts, comes on. goes off, then comes on, bike shuts off, then goes off...AHHHHHHH.. ill post what codes i have.
whiterabbit is offline  
post #5 of 5 (permalink) Old 07-31-2011, 08:44 PM
Senior Member
Sh4dowsJudgment's Avatar
Joined: Jul 2010
From: Livonia Mi
I Ride: 2005 ZX6R C1

Posts: 519
since the FI light is no longer on make sure you use DEALER MODE 2 by tapping the ground wire 5 times in 2 seconds., have a peice of paper next to you and right them all down. then clear the history by pulling in the clutch for 5 seconds and wait for it to happen again if it does, then check dealer mode 2 again.

2005 ZX636C1
Shorty Levers
Integrated Tail light
12000k HID's (HI/Low)
Chameleon(Pearlescent) Paint Job Silver/Green
Vortex Frame Sliders
Zero Gravity Double Bubble Windscreen
Full Titanium Muzzy's Exhaust(Lava Tape Wrapped)
Samco Coolant Hoses(Black)
Powercommander III
APE Manual CCT
K&N Airfilter
Kleen Air Mod
Jumper Mod
GP Shift Style
Öhlins steering damper
Sh4dowsJudgment is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the ZX Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

For the best viewing experience please update your browser to Google Chrome