Wiring for 89 Ninja ZX750 H1 : Kawasaki ZX Forums: Kawasaki Ninja Forum
» Sponsors
» Insurance
Go Back   ZX Forums > ZX Forums > Mechanical & Technical

Reply
 
LinkBack Thread Tools
Old 08-25-2010, 07:43 PM   #1 (permalink)
Newbie
 
Joined: Aug 2010
From: California

Posts: 17
Wiring for 89 Ninja ZX750 H1

Hi all, I just bought an 89 ZX7 with some electrical issues. It wasn't till right after I paid for the bike that the problems started when I tried to start it to ride it home. When I pressed the start button, the small wire going to the solenoid got hot and started to smoke. I ended up putting the bike in a van and brought it home. I think someone may have used a solenoid that is for a different bike which is why some of the wires have been mickey moused. It appears that they ran their own wires from the start button up on the handlebars to the solenoid rather than going through the wiring harness. I have cut off the "added on" wires and reattached the stock green connector to the end of the wires on the start, off/run buttons, but do not see where to plug it in, I just know that it connects somewhere near the front of the bike by the length of the wires. I also do not know where the small wire for the solenoid goes, I just know that it must connect into the main wiring harness somewhere. Is there a manual or pictures on the web somewhere that would have actual pictures of these, the connectors, and where they plug into rather than just a wiring diagram? Wiring diagrams confuse me and I have a hard time trying to figure them out. I would like to ride the bike before the summer is over. thanks in advance.

Last edited by medicinalmotorcycle; 08-25-2010 at 07:54 PM.
medicinalmotorcycle is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-25-2010, 08:17 PM   #2 (permalink)
Senior Member
 
2fat2fly's Avatar
 
Joined: Oct 2008
From: Ohio
I Ride: 91 ZX7R,93 ZX7R,00 ZX12R, 87 YSR50, 87 GSXR750,93 ZX7, 92 ZX7

Posts: 4,872
This might help:

__________________
"Any man who thinks he can be happy and prosperous by letting the government take care of him --- better take a closer look at the American Indian." Henry Ford

My ZX12R Build:
http://www.zxforums.com/forums/zx-12...ave-today.html

My 1993 ZX7R (M1)
http://www.zxforums.com/forums/zx-7r...r-real-m1.html

http://www.zxforums.com/forums/zx-7r...-m1-naked.html
2fat2fly is offline   Reply With Quote
Old 08-25-2010, 08:23 PM   #3 (permalink)
Senior Member
 
90zxr750's Avatar
 
Joined: Sep 2009
From: ohio
I Ride: 2004 zx10r

Posts: 7,303
damn i coulda used that diagram 6 months ago
__________________
Sir Dino Ridin, Acoustic Smasher Punk Whore of ZXF

2004 zx10r

1990 zx-7 SOLD march 2012
90zxr750 is offline   Reply With Quote
Old 08-26-2010, 05:14 AM   #4 (permalink)
Senior Member
 
2fat2fly's Avatar
 
Joined: Oct 2008
From: Ohio
I Ride: 91 ZX7R,93 ZX7R,00 ZX12R, 87 YSR50, 87 GSXR750,93 ZX7, 92 ZX7

Posts: 4,872
Quote:
Originally Posted by 90zxr750 View Post
damn i coulda used that diagram 6 months ago
Didn't know you needed one.
__________________
"Any man who thinks he can be happy and prosperous by letting the government take care of him --- better take a closer look at the American Indian." Henry Ford

My ZX12R Build:
http://www.zxforums.com/forums/zx-12...ave-today.html

My 1993 ZX7R (M1)
http://www.zxforums.com/forums/zx-7r...r-real-m1.html

http://www.zxforums.com/forums/zx-7r...-m1-naked.html
2fat2fly is offline   Reply With Quote
Old 08-26-2010, 11:52 PM   #5 (permalink)
Newbie
 
Joined: Aug 2010
From: California

Posts: 17
Thanks for posting the wiring diagram 2fat2fly, it should come in handy in the future when I learn how to read it. Am I the only one who can't read wiring diagrams? At this time, I really just need to know where the connector for the start, off/run buttons plugs into. Is it somewhere right behind the headlights or underneath the gas tank?
medicinalmotorcycle is offline   Reply With Quote
Old 08-27-2010, 03:51 PM   #6 (permalink)
Senior Member
 
kawa kid's Avatar
 
Joined: Apr 2008
From: Pacific Northwest

Posts: 454
It's under the gas tank. There should be 6 wires coming from the run/off switch that are attached to a green connector. That green connector plugs into the other green connector, which should be located under the gas tank.
kawa kid is offline   Reply With Quote
Old 08-28-2010, 04:14 AM   #7 (permalink)
Newbie
 
Joined: Aug 2010
From: California

Posts: 17
Ok, sounds like some good info Kawa kid. I found 6 wires together under the tank coming off the wiring harness which had the connector cut off and weren't connected to anything. These must be the wires I need to connect into. If I had the connector for the harness, I could just re-attach it and connect the 2 green connectors together, but I don't. So I'm thinking about putting my own connectors on each individual wire and connecting them that way. Problem is the colors of the wires on the harness are not all the same as the colors of the wires on the start, off/run buttons, so I am not sure which wires to connect together. I looked at the wires and took some notes, here they are:

Wires on Start, Off/Run Buttons, Brake light switch:

Black w Red tracer - Start
Black w Red tracer - Start
Yellow w Red tracer - Off/Run
Red - Off/Run
Black - Brake light switch
Black - Brake light switch


Harness:

Black w Red tracer
Blue w Red tracer
Brown
Red
Red
Yellow

Any idea which wires coming from the buttons to connect to the wires on the harness?

Last edited by medicinalmotorcycle; 08-28-2010 at 04:22 AM.
medicinalmotorcycle is offline   Reply With Quote
Old 08-28-2010, 03:51 PM   #8 (permalink)
Senior Member
 
kawa kid's Avatar
 
Joined: Apr 2008
From: Pacific Northwest

Posts: 454
Ok,
From the harness Blue/Red tracer to Black.
From harness, black/Red tracer to Balck/Red tracer
From harness, Red to Red
From harness, Brown to Black
From harness, Yellow to Yellow/Red tracer
kawa kid is offline   Reply With Quote
Old 08-28-2010, 04:03 PM   #9 (permalink)
Senior Member
 
kawa kid's Avatar
 
Joined: Apr 2008
From: Pacific Northwest

Posts: 454
I haven't done this yet but her is the first attempt.
http://s982.photobucket.com/albums/a...view=slideshow
kawa kid is offline   Reply With Quote
Old 08-30-2010, 04:04 AM   #10 (permalink)
Newbie
 
Joined: Aug 2010
From: California

Posts: 17
Ok, thanks for the info and picture Kawa kid. I am starting to get somewhere. I touched the blue/red tracer and brown wires on the harness together to see if the brake light would come on and it did, so I am on the right path. As far as the 4 other wires for start and off/run, I haven't been able to check those because I don't have the right solenoid, I need to buy the right solenoid for the bike. I looked at the album of your bike Kawa kid and discovered that the red connector for the solenoid has also been cut off from the harness on my bike which explains what those 4 wires with no connectors I see are for. I'm not too sure I can put my own connectors on those wires for the solenoid, I guess I won't know that until I have the solenoid and can look at it. You have an extra solenoid for the '89 ZX-7 you want to sell Kawa kid?

Last edited by medicinalmotorcycle; 08-30-2010 at 04:11 AM.
medicinalmotorcycle is offline   Reply With Quote
Old 08-30-2010, 07:12 AM   #11 (permalink)
Senior Member
 
kawa kid's Avatar
 
Joined: Apr 2008
From: Pacific Northwest

Posts: 454
Sorry, I don't.
kawa kid is offline   Reply With Quote
Old 12-19-2011, 04:18 AM   #12 (permalink)
Newbie
 
Joined: Dec 2011
From: Minnesota

Posts: 3
Thumbs up Ignition switch wiring...

Glad to see someone with a readable Diagram, Thank you for all the kawi ryders that have needed it. I tried to get by with a russian diagram and german one with little luck the last year until now. shortened my wire loom a ft-1/2 and revised my component placement for a saddle seat mod...

Problem is that i have had a tampered-with harness for yami controls and upgraded with HID bi-xenon and wireless keyfob, so then now i'm trying to figure the yellow wire (leading up from the killswitch) to??? Brown or white, or both (leading up from Junction box)?
By the looks of it on the German diagrams: Brown, Grey, and white, go to the key-switch... There's no grey wire in my whole engine circuit, or in the accurate one for my bike specific-to the start of this forum. I'm pretty sure the white wire switches my yellow wire for running the motor, Confused as to why brown would be on it? and if it runs through the switch to my kill-switch like the German diagram shows...

Last edited by TradeM; 12-21-2011 at 04:18 PM.
TradeM is offline   Reply With Quote
Old 12-21-2011, 04:33 PM   #13 (permalink)
Newbie
 
Joined: Dec 2011
From: Minnesota

Posts: 3
Ignition switch wiring...

http://imageshack.us/photo/my-images/526/igns.jpg/

ZX wont let it upload the image for the German diagram because its too big... untill thumbnail sized and unreadable.
This is the 87-90 zx750f which my bike has same motor and essentially the same electronics.
TradeM is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 10:06 PM.



Powered by: vBulletin 3.8.5
Copyright ©2005-2010 - www.zxforums.com
Website designed and developed by Random Computers
Motorcycle News, Videos and Reviews
Honda Grom Forum Harley Davidson Forum Honda 600RR Kawasaki Forum Yamaha R6 Forum Yamaha FZ-09 Forum
1199 Panigale Forum Roadglide Forum Honda CBR1000 Forum Vulcan Forum Yamaha R1 Forum Yamaha R3 Forum
Ducati Monster Forum Harley Forums Honda CBR250R Forum ZX10R Forum Star Raider Forum Yamaha Viking Forum
Suzuki GSXR Forum V-Rod Forums Honda Shadow Forum Kawasaki Motorcycle Forum Star Warrior Forum KTM Duke 390 Forum
SV650 Forum BMW S1000RR Forum Honda Fury Forum Kawasaki Versys Forum Drag Racing Forum Ducati 899 Panigale Forum
Suzuki V-Strom BMW K1600 Triumph Forum Victory Forums Sportbikes BMW NineT Forum
Volusia Forum BMW F800 Forum Triumph 675 Forum MV Agusta Forum HD Street Forum Suzuki GW250 Forum
Yamaha Motorcycles Victory Gunner Forum Honda Vultus Forum HD LiveWire Forum Ninja H2 Forum Ducati Scrambler Forum

Search Engine Optimization by vBSEO 3.6.0